External incident: Rabobank

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 09:49 CET

Monitoring

Payouts are being successfully processed again, we will continue to monitor.
Posted Nov 10, 2025 - 09:44 CET

Investigating

Rabobank reports issues with processing S(ICT) payouts and refunds, which have not been processed since 07:41 CEST.
More information: https://developer.rabobank.com/status
Posted Nov 10, 2025 - 09:29 CET
This incident affected: Payment methods (S(ICT) payouts and refunds).