Partial Outage — Instant Payouts and Refunds

Incident Report for PAY.

Resolved

The issue affecting instant payouts and instant refunds has been resolved.
Our payment supplier has restored full service, and all systems are now operating normally.

We will continue to monitor the service to ensure stability.
Thank you for your patience.
Posted Nov 02, 2025 - 14:23 CET

Update

While the issue with our payment supplier continues to affect instant payouts and instant refunds, pending payments will still be processed on Monday, November 3, using our fallback processing method.

Instant functionality remains unavailable at this time. We will continue to monitor the situation and provide further updates as soon as the supplier has restored full service.

We apologize for the ongoing inconvenience and appreciate your patience and understanding.
Posted Nov 02, 2025 - 12:22 CET

Update

Our supplier has indicated that the expected resolution date is Monday, November 3.
Posted Nov 02, 2025 - 09:47 CET

Investigating

We are currently experiencing an issue with our payment supplier that affects the processing of instant payouts and instant refunds.
Some transactions may not be processed successfully at this time.

The root cause has been traced to our payment supplier. As this lies outside our infrastructure, we are monitoring the situation and will update this page once the supplier restores full functionality.

We apologize for the inconvenience and appreciate your understanding.
Posted Nov 01, 2025 - 19:32 CET
This incident affected: Payment methods (Instant SEPA payments).