Instant Payments Route

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 08:47 CET

Investigating

Payouts and Instant Refunds processed via Rabobank are currently impacted and may be delayed or fail.
Please note that regular refunds are not affected and are being processed as usual.

Payin's via iDEAL of banktransfer are not affected.

More information: https://www.rabobank.nl/particulieren/storing
Posted Feb 11, 2026 - 08:19 CET
This incident affected: Payment methods (S(ICT) payouts and refunds).