External outage: iDEAL
Incident Report for PAY.
Resolved
iDEAL implemented a fix. The incident has been resolved.
Posted Oct 22, 2024 - 17:12 CEST
Monitoring
Between 16:54 and 16:59, there was a disruption on the iDEAL network, preventing transactions from being completed. The issue now appears to be resolved.
Posted Oct 22, 2024 - 17:08 CEST
This incident affected: Payments methods (iDEAL).