Connectivity issues with SIM cards

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Sep 13, 2026 - 16:00 CEST

Update

We are continuing to monitor for any further issues.
Posted Sep 13, 2026 - 15:01 CEST

Monitoring

The connectivity issues affecting some SIM cards appear to have been resolved. Terminals should now be able to connect to the mobile network again.

In some cases, a terminal restart may be required to restore the connection.

We will continue to monitor the situation closely.
Posted Sep 13, 2026 - 15:01 CEST

Update

Instructions on how to connect your terminal to Wi-Fi can be found here:
https://support.pay.nl/en/knowledge/connecting-your-pax-terminals-to-wi-fi-en

When accessing the settings on the terminal, you may be prompted for a settings password. The password is 000000.
Posted Sep 13, 2026 - 13:35 CEST

Investigating

We are currently experiencing an external network issue affecting some SIM cards. As a result, affected devices may be unable to establish a mobile data connection.

The issue is located within the network of our SIM provider and is currently being investigated by their engineering teams.


If possible, we recommend connecting the affected device via Wi-Fi or using a mobile hotspot until the issue has been resolved.

We are monitoring the situation and will provide an update as soon as more information becomes available.
Posted Sep 13, 2026 - 13:09 CEST
This incident affected: Configuration and operations (Global Management System) (Terminal management).