External outage: PayPal

Incident Report for PAY.

Resolved

The incident has been resolved. Since 23:20 CEST, PayPal transactions have been processed correctly again. We will continue to monitor the results closely.
Posted Apr 08, 2025 - 23:28 CEST

Investigating

PayPal has been experiencing an outage since 22:04 CEST, which is currently preventing transactions from being processed
Posted Apr 08, 2025 - 23:22 CEST
This incident affected: Payments methods (PayPal).