The issue affecting Mastercard payments has been resolved. Since 07:36, transaction success rates have returned to normal and remained stable.
We will continue to monitor Mastercard payment traffic closely.
Posted Aug 15, 2026 - 07:57 CEST
Update
We are seeing an improvement in Mastercard payment traffic, with transaction success rates recovering. We will continue to monitor the situation and provide further updates if necessary.
Posted Aug 15, 2026 - 07:45 CEST
Investigating
Since approximately 06:00 this morning, we have been experiencing a disruption affecting some Mastercard transactions. As a result, some Mastercard payments may be declined or may not be completed successfully.
The disruption appears to be external to our platform.
We will provide an update as soon as more information becomes available.
We apologize for any inconvenience this may cause.
Posted Aug 15, 2026 - 07:43 CEST
This incident affected: Payment methods (Card not present (Debit- & Creditcards), Card present (Terminal payments), Creditcard (Visa Mastercard)).