Delay in daily clearing

Incident Report for PAY.

Resolved

The clearing batches have just been submitted successfully.
Posted Sep 02, 2026 - 13:00 CEST

Investigating

Due to a technical issue at Rabobank, we have not yet been able to submit the clearing batch. As a result, merchants will receive their payments later than usual.
Posted Sep 02, 2026 - 12:30 CEST
This incident affected: Clearing and settlement.