External incident: Rabobank
Incident Report for PAY.
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 15:22 CET
Identified
Rabobank is currently experiencing a disruption, causing iDEAL transactions to be unavailable through this bank. For more information, please visit: https://availability.ideal.nl/
Posted Feb 01, 2024 - 15:11 CET
This incident affected: Payments methods (iDEAL).