Incident: Klarna Pay in Full

Incident Report for PAY.

Resolved

All affected merchants have been informed about Klarna's revised policy regarding the payment option Klarna Pay in Full.
Posted Nov 11, 2025 - 09:38 CET

Investigating

At this moment there are issues with processing transactions via the payment method Klarna Pay in Full. We are in contact with Klarna to investigate this issue.
Posted Nov 05, 2025 - 09:21 CET
This incident affected: Payment methods (Klarna Pay in Full).