External incident: Terminal issues

Incident Report for PAY.

Resolved

PIN transactions are available again, the issue has been resolved.
Posted Sep 23, 2025 - 10:10 CEST

Investigating

At the moment, there are issues with processing PIN transactions for CCV terminals. The cause is currently being investigated.
Posted Sep 23, 2025 - 09:58 CEST
This incident affected: Payment methods (Instore Payments).