External incident: iDEAL

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 15:44 CET

Update

For more information about the outage, please visit: https://availability.ideal.nl/
Posted Mar 25, 2026 - 15:42 CET

Investigating

iDEAL is currently experiencing an outage, which means that transactions via iDEAL are not possible at the moment
Posted Mar 25, 2026 - 15:40 CET
This incident affected: Payment methods (iDEAL).