Front page en Phone Services

Incident Report for PAY.

Resolved

Cloudflare looks restored, iDEAL payment volume is recovering
Posted Dec 05, 2025 - 10:13 CET

Update

A Cloudflare issue is impacting our frontend and calling system. iDEAL is currently experiencing degraded performance, so iDEAL payments will be slower or fail. Other payments are processing normally
Posted Dec 05, 2025 - 10:07 CET

Update

It seems that also iDEAL has a lower performance at the moment.
Posted Dec 05, 2025 - 10:05 CET

Monitoring

We’re aware of an issue at Cloudflare that’s impacting the PAY.nl frontend and our calling/Support system. Payment processing is continuing as normal.
Posted Dec 05, 2025 - 09:57 CET
This incident affected: Support, communication and information (Support Ticket Center, Support phone (+31 88 88 666 22), Support chat, Boarding & Care (+31 88 88 666 47), www.Pay.nl (frontpage)) and Payment methods (iDEAL, iDIN).