Second-chance emails issue

Incident Report for PAY.

Resolved

This incident has been resolved
Posted Dec 15, 2025 - 10:34 CET

Monitoring

We have identified the cause of the duplicate emails. You will now receive one second-chance email again, as usual. We are currently monitoring the situation
Posted Dec 15, 2025 - 10:10 CET

Investigating

Due to an issue in the delivery of second-chance emails, a consumer may have received multiple emails for the same order. We are currently investigating the cause. If the order has already been paid, the consumer can ignore any follow-up emails
Posted Dec 15, 2025 - 09:35 CET
This incident affected: Configuration and operations (Global Management System) (Transaction management).