External incident: Terminal issues

Incident Report for PAY.

Resolved

This issue has been closed. If you still experience any problems with your terminal, please follow the steps described at https://docs.pay.nl/instorepayments?language=en#contact-tms
Posted Oct 23, 2025 - 08:54 CEST

Update

We are continuing to monitor for any further issues.
Posted Oct 22, 2025 - 13:50 CEST

Update

We are continuing to monitor for any further issues.
Posted Oct 22, 2025 - 13:45 CEST

Monitoring

CCV has resolved the issue. If you are still unable to process PIN transactions, please perform a "Contact TMS update" on your PIN terminal: https://docs.pay.nl/instorepayments?language=en#contact-tms
Posted Oct 22, 2025 - 11:17 CEST

Identified

CCV is currently working on a fix. As a temporary workaround, we recommend using our SoftPOS app (https://www.pay.nl/en/softpos) to continue processing payments.
Posted Oct 22, 2025 - 10:13 CEST

Update

CCV has confirmed the outage and is currently working on a solution. We’ll let you know as soon as an update is available.
Posted Oct 22, 2025 - 10:07 CEST

Investigating

At the moment, there are issues with processing PIN transactions for CCV terminals. The cause is currently being investigated.
Posted Oct 22, 2025 - 08:51 CEST
This incident affected: Payment methods (Instore Payments).