External incident: Rabobank

Incident Report for PAY.

Resolved

This incident has been resolved
Posted Jul 02, 2025 - 09:04 CEST

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 14:14 CEST

Investigating

Rabobank reports issues with bank payments, causing (instant) payouts and bank transfers to be processed with delays. iDEAL payments via this bank are not affected
Posted Jul 01, 2025 - 14:13 CEST
This incident affected: Payment methods (Instant SEPA payments).