Incident: Refunds

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 09:35 CET

Monitoring

A fix has been implemented. Refunds are now possible again, we will continue to monitor the results.
Posted Nov 25, 2025 - 09:32 CET

Investigating

At this moment we are experiencing an issue with processing refunds. We expect to resolve this problem shortly and kindly ask you to postpone the refunds for now.
Posted Nov 25, 2025 - 09:19 CET
This incident affected: Configuration and operations (Global Management System) (Transaction management).