External incident: Rabobank

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 13:01 CEST

Investigating

Rabobank has been experiencing technical issues since 11:25, preventing users from successfully completing iDEAL transactions through this bank.
Posted Sep 02, 2026 - 12:08 CEST
This incident affected: Payment methods (iDEAL).