Network issues
Incident Report for PAY.
Resolved
The incident has been resolved.
Posted Apr 13, 2023 - 16:07 CEST
Update
Services seem to be operational again, conversion rates have recovered to normal levels. We keep monitoring the results closely
Posted Apr 13, 2023 - 15:55 CEST
Investigating
We are currently experiencing a degraded performance on our network. We're investigating the issue.
Posted Apr 13, 2023 - 15:33 CEST
This incident affected: Configuration & Operations (Global Management System) (MY.pay.nl, PAY.APP, Transaction Management, Operational Management, Registration & Configuration), Payment processing (Transaction Gateway Units) (Maincore: pay.nl), Support, Communication & Information (Support Ticket Center, Support phone (+31 88888 666 22), Support chat, Boarding & Care (+31 88 88 666 47)), Payments methods (Riverty, Apple Pay, Bancontact, Billink, Creditclick, Creditcard (Visa Mastercard), Card not present (Debit- & Creditcards), Card present (Terminal Payments), 3DSecure for Strong Customer Authentication, Direct Debit (Sepa incasso), Giftcards, Giropay, Google Pay, iDEAL, Instore Payments, In3, Klarna, Maestro, Multibanco, Pay by phone, Przelewy24, Payconiq, PayPal, Paysafecard, Sofort Banking, SprayPay, Trustly, iDIN, EPS Uberweisung), and Clearing & Settlement.