Netwerk issues

Incident Report for PAY.

Resolved

DDoS mitigation has been activated, and all services are currently stable.
Posted Jul 10, 2026 - 17:40 CEST

Update

The issue has been mitigated, and the network is stable again. We are continuing to monitor the situation closely.
Posted Jul 10, 2026 - 17:19 CEST

Investigating

Our network provider is currently experiencing a DDoS attack. The Multicore platform remains fast and fully available. If necessary, you can temporarily switch your core endpoint to payments.nl.
Posted Jul 10, 2026 - 17:16 CEST
This incident affected: Configuration and operations (Global Management System) (MY.pay.nl) and Payment processing (Transaction Gateway Units) (Single core: pay.nl (legacy)).