Downgraded performance Bancontact payments.

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Mar 21, 2026 - 12:12 CET

Identified

We are currently experiencing a degradation outside of the Pay.nl platform affecting Bancontact payments.
As a result, some consumers may be unable to complete their payment, which can lead to a lower success rate for this payment methods.

https://allestoringen.be/storing/bancontact-mr-cash/
Posted Mar 21, 2026 - 11:21 CET
This incident affected: Payment methods (Bancontact).