Incident: 24/7 Merchant Support Phonenumber
Incident Report for PAY.
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 14:54 CEST
Investigating
Our 0900 - 24/7 Merchant Support Phonenumber is currently unreachable. For urgent issue reports, please contact us at the following phone number: +31 (0) 8888 666 88.
Posted Apr 19, 2024 - 21:46 CEST
This incident affected: Support, Communication & Information (24/7 Merchant Support Phone).