Incident: Dynamic donation and payment links

Incident Report for PAY.

Resolved

This incident has been resolved
Posted May 19, 2026 - 12:52 CEST

Investigating

There is currently an issue causing Dynamic Donations and payment links not to be displayed correctly. Standard payment links are still functioning as expected.
Posted May 19, 2026 - 10:32 CEST