Incident: Registration and reporting

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 18:25 CEST

Update

Registering a merchant account is possible again. We are currently working on making the 'quick search' option available again. We expect however reduced availability of this feature for the next few hours.
Posted Sep 15, 2025 - 17:02 CEST

Investigating

At the moment, the report function within our Admin Panel is delayed, and new Merchant accounts cannot be registered. Our team is looking into this. This issue does not affect transaction processing
Posted Sep 15, 2025 - 14:43 CEST
This incident affected: Configuration and operations (Global Management System) (MY.pay.nl, Registration and configuration).