External incident: Bancontact

Incident Report for PAY.

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 12:34 CEST

Investigating

Bancontact is currently experiencing an outage, preventing transactions from being completed.
Posted Mar 30, 2026 - 12:21 CEST
This incident affected: Payment methods (Bancontact).